Layouts - AutoCAD

  • All Borders include
    • Left Margin - 3 hole punch
    • Top Margin - Millimeters ruler, Architect Scale, Civil Engineer Scale, Machinist Scale, Inches ruler
    • Right Margin - GD&T
    • Bottom Margin - File Name and Path, ASME Dimension Standard used, Sheet Size, Plot Date
  • Letter - Landscape
  • Letter - Portrait
  • Tabloid - Landscape
  • Title Blocks

Inventor Project Setup

  1. Background
    • Projects vs Application Options
      • I think Projects gives you more flexibility
      • Application Options: File → Options → File tab
        • Default templates → Point this to the network location
  2. Determine where on the network your going to save your work, this is the Project Location
    1. Sharepoint at COJ: C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\GISE\Designs
    2. Sharepoint at Home: C:\Users\JeffJourneyJensen\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\GISE\Designs
    3. Sharepoint at Journey C:\Users\JeffJourneyJensen\journeyeducation.org\Jensen - Documents
    4. Sharepoint at CSI: C:\Users\jjensen5\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\GISE\Designs
  3. Copy Inventor Templates and Design Data folders to the network using Windows Explorer
    1. FROM→ C:\Users\Public\Documents\Autodesk\Inventor 2019\Design Data
    2. TO→ C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Design Data
    3. FROM→ C:\Users\Public\Documents\Autodesk\Inventor 2019\Templates
    4. TO→ C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Templates
  4. Create Project in Inventor
    1. Open Inventor, should have the “Get Started” tab
    2. Projects (from the ribbon, just right of open) opens a new dialog box
    3. New
      1. New Single User Project - > Next
      2. Name: GISE
      3. Project (Workspace) Folder: C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\
    4. Use Style Library = Read-Write
    5. Workspace edit to “.\Designs”
      1. C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Designs
    6. Folder Options
      1. Templates = “.\Templates\
        1. C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Templates
      2. Design Data = ”.\Design Data\
        1. C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Design Data
    7. Save
    8. Done
  5. Create a workspace (default file open location) under the Project Location (all my work is saved here)
    1. C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Designs
  6. Edit Styles
    1. Manage → Styles Editor
    2. Dimension
      • Feet and Inches: 6'-4 1/2“ if can't be done try 76-1/2” or 76 1/2“ where the fraction is horizontal
      • Units
        • “UNLESS OTHERWISE SPECIFIED, ALL DIMENSIONS ARE IN INCHES (IN)”
        • “UNLESS OTHERWISE SPECIFIED, ALL DIMENSIONS ARE IN MILLIMETERS (mm)”
          • (ASME-Y14.100-2004 Engineering Drawing Practices, p. 8)
        • 0.9 mm (don't use .9 for millimeters)
        • .9 IN (don't use 0.9 for inches)
        • “A zero is not used before the decimal point for values less than 1 in”
        • Figure 1-0 Decimal Inch Dimensioning
        • Figure 1-0 Millimeter Dimensioning
    • Tolerances
      • Change the tolerance dimension to size/text height 0.07”
      • Open InchDecimal.dwg → Manage → Styles Editor → Dimension → Inch Decimal → Text tab → Size 0.07“
      • Figure 1-0 Tolerance Size
    1. Text → Note Text (ANSI)
      1. Font: Arial Narrow
      2. Text Height: 0.060 in
    2. Manage → Save (updates the network Template and Design Data files)
  7. Edit Template
    1. Open Template File (which one?)
      1. Sheet Metal (in).ipt
      2. Standard (in).ipt
    2. Manage → Update (syncs the Template and Design Data changes with the template files)
      1. Style Conflict warning message
        1. The following style definitions in template C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\GISE\Templates\Standard.dw differ from the definitions in the style library; the style library definitions will be used.
        2. Dimension: Architectural (ANSI), Layers: 0, Standard:Default Standard (ANSI), Table:Table (ANSI), Text:Label Text(ANSI), Text Note Text (ANSI)
        3. If the style definitions in the style library are intended for the new document, update the template with the new style definitions.
        4. If the style definitions in the template are intended for the new document, remove these styles from your style library using the Style Library Manager.
        5. Figure 1-0 Style Conflict Error
      2. I don't see any styles to update

Style Manager

  • Step 1 - make a change to the style
  • Step 2 - Save the change from the drawing into the Library (SAVE)
  • Step 3 - open the template
  • Step 4 - Update the template with changes in the Library (UPDATE)
  • File → Manage → Projects → Folder Options → Design Data (Styles, etc.) = [Default]
  • local styles - saved in the drawing .idw
  • global styles - saved in C:\Users\Public\Documents\Autodesk\Inventor 2019\Design Data

Inventor Drawing Problems

  • Seems the best workflow is create the model in Inventor, then xref into AutoCAD for the custom title block
  • Drawing Resources
    • First change the sheet size then add the drawing resources like borders and title blocks
  • Logos and Images
    • if you insert a linked image in a border or title block, you cannot delete it. Need to uncheck the link box when adding
    • If you import an AutoCAD drawing with an image, Inventor makes it a linked image so you cannot delete it
  • Multiline MTEXT
    • appears the justification and tabs are not supported by Inventor, seems the best solution is to use single line MTEXT
  • AutoCAD Blocks and Clipboard Copy & Paste
    • Hatches are not support, have to recreate within Inventor

Inventor Title Blocks and Borders

  • Template - journeyeducationorg.sharepoint.com\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Templates\InchDecimal.dwg
  • Title Blocks (special kind of sketch symbol - can only have one title block per drawing)
    • Save dynamic text (anything that needs to change between drawings). Problem - can't snap AutoCAD blocks or Sketch Geometry to midpoints, end points, etc. Seems it only snaps to the corner of a border.
    • Title block or strip
    • Logo
    • iProperties (DWGPROPS and FIELDS) - best way to populate a Title Block in AutoCAD
    • Prompted Entries (ATTDEF)
      • Appears you can't have static text with a Prompted Entry Text Field, solution to create two text objects, for example
        • PLOT DATE (YMD): <Enter Date YYYYMMDD>
          • PLOT DATE (YMD): is the static text
          • <Enter Date YYYYMMDD> is the prompted entry text
        • Create this as Sketch Symbol instead of in the title block
  • Borders
    • Can insert AutoCAD blocks
    • Save static text.
      • Issue #1 - can't insert AutoCAD blocks or Sketch Geometry in a border.
      • Issue #2 - only one layer allowed, Borders, so have to change color & linetype by object
    • Border
    • Ruler (inch and mm)
    • 3 Hole Punch
    • GD&T symbols
  • Sketch Symbols

Drawing Layouts

  • Background
    • Do all plotting using AutoCAD instead of Inventor. Reasons:
    • Inventor Sketch Symbols (imported AutoCAD blocks) can NOT be imported into a Title Block
    • Inventor cannot add a plot stamp date
    • Inventor cannot plot in grayscale, WYSIWYG no plot styles (.ctb or .stb) like with AutoCAD
    • Inventor layers don't support transparency, so if you want a faded line, need to use a light gray color
    • Inventor cannot group objects - if you want to move a title block, each entity has to be moved individually
      • Inventor Drawing Resources are grouped together, unknown how to group objects together in Inventor
    • Inventor cannot import images/graphics in the drawing.
      • I think Inventor recognizes .bmp or .gif
    • Inventor custom title blocks and borders are difficult to use (draw, move, edit)
      • Works ok, if setup correctly
    • Inventor doesn't support AutoCAD Blocks with
      • MTEXT
      • HATCH patterns (I think SOLID hatch pattern works if based on lines/polylines)
      • Annotative text styles
      • SPLINE
        • use SPLINEEDIT to convert the spline into a polyline
  • Step 0 - Projects (.ipj) - a workspace
    • Tells Inventor where to save files, can be a network drive
    • Projects use relative paths rather than absolute paths when the project locations such as the workspace, workgroup, or libraries are in a subfolder of the folder that contains the project file. About Projects Autodesk Inventor 2019
    • C:\Users\JeffJourneyJensen\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects (home computer)
    • Can only have one active project open at a time
    • Design Data Folder - To Move the Design Data Folder
  • Step 1 - create drawing template GISE.idw
  • Step 1 - create the title block in AutoCAD
  • Step 2 - using Inventor, open the AutoCAD title block
    • Options… → Non-Inventor DWG File → Import
    • DWG/DXF File Wizard → Read Content From: AutoCAD or AutoCAD Mechanical File
      • Import Destination Options
        • Import Files Units → Detected Units → inch
        • Destination for 2D data → Title Block
        • Templates
          • Drawing Template → Standard.idw
          • Sheet Size: A
    • Error: Undefined Template creation in progress. Insert not done. Please complete and close creation in progress and try again.
  • Step 3 - save as Autodesk Inventor DWG in the Templates folder
  • Step 4 - drawing resources are like AutoCAD Design Center (ADC) storing blocks, layout shows an instance of the border and title block, if you delete the border, it is still available in the drawing resources
  • SharePoint journeyeducation.org\Jensen-Documents\JeffJensen\GISEngineering\Inventor\templates\A-Landscape-in-Inventor.dwg
  • Help

Custom Title Block

  1. Open Inventor Drawing
  2. Save Copy as template
    1. Inventor Drawing Files (*.idw)
    2. SharePoint GISEngineering\templates\GISE-A-Landscape-in.idw
    3. SharePoint GISEngineering\Inventor\projects\Templates\InchDecimal.dwg
    4. “The location of the selected file is not in the search path of the active project file”, just click Yes
  3. Sheet:1 delete Default Border and ANSI - Large title block
    1. Edit Sheet: Size A, Name GISE-A

Title Block - Letter Simple Portrait

  • Manage → Styles Editor → Layers
    • Title (ANSI) Line Weight = 0.020 in default (don't change this, because then will have to change template and library, which other end users might not want)
  • Line Properties - change width to 0.01 in

Logo - Image

  • Essential Question - What is the best way to add a company logo to an Inventor Drawing?
    • Option 1 - Fastest - use an image
    • Option 2 - redraw the logo within Inventor
    • Option 3 - AutoCAD block of logo
      • Problems
        • AutoCAD blocks are inserted as Inventor Sketch Symbols, but these ARE NOT allowed in Inventor Title Blocks
        • Can manually place a sketch symbol in the drawing but CANNOT place is accurately, no way to dimension to it
        • Inventor DWG block import doesn't support - MTEXT, Annotative Styles, SPLINES, HATCH (appears Solid fill works if based on lines/polylines)
  • Essential Question - How do I import my PNG/JPG logo into Inventor Drawing?
  • Model Browser: Drawing Resources → Sketch Symbols → Define New Symbol
  • Ribbon → Insert panel → Image → single click where to insert the image
  • Browse to the logo file location
    • to embed image, make sure Link is unchecked
    • Inventor sketches can include .BMP, .GIF, .JPG, and .PNG images
  • References

Logo - Vector DWG, AI

  • Essential Question - How do I import my Adobe Illustrator (.ai) logo into Inventor Drawing?
  • Step 1 - Adobe Illustrator CC
    • open .ai file in Illustrator CC
    • Set Units
      • File → Document Setup - Units Inches
    • create Artboard 1”x1“
      • Window → Artboards
      • Artboard Options (3 horizontal lines)
      • Present: Custom
        • width: 1”
        • height: 1“
    • Export → Export As
      • DWGs don't have an option to export based on a Artboard, so make sure Illustrator only has one Artboard
    • save as .dwg (version 2012)
  • Step 2 - AutoCAD 2018
    • open .dwg
    • save as version 2018
  • Step 3 - Inventor

Sheet Number 1 of 3

  • 11×8.5:1 → Letter-Simple-Landscape → right click Edit
  • Sheet Properties → Sheet Number
  • Drawing Properties → Number of sheets
  • click Add Text Parameters button
  • Title Block - Sheet Number

Drawing Resources - AutoCAD Blocks

  • translated blocks can only have
    • 2D geometry (lines and arcs)
    • MTEXT allowed but not with annotative text styles
    • hatches are not supported - use PLINE with WIDTH option (e.g. WIDTH=0.0625) to draw a solid fill rectangle
  • unable to Import Block
  • Step 1 - Inventor open Journey Sharepoint/JeffJensenGISEngineering/Inventor/projects/Templates/InchDecimal.dwg
  • Step 2 - Model Browser → Drawing Resources → AutoCAD Blocks → right click Import AutoCAD Blocks
  • Step 3 - browse to ScalesRulers/PaperSpace-Inch/Ruler-Arch-all.dwg
    • select Ruler-Arch-1-16th.dwg
  • Step 4 - place in drawing
  • [Q] how do I change 1) Set Insertion Point Grip and 2) Connection Point Grip of an AutoCAD block?

Drawing Resources - Sketch Symbols

  • Sketch symbols are created in a drawing or template, they can contain geometry, text, iProperties and imported bitmap images (.bmp either linked or embedded)
  • To make sketch symbols available to all new drawings, add them to the template you use to create drawings or store them in a symbol library
  • To place and move a sketch symbol precisely on a drawing, add one insert point and several connection points.
  • It appears Sketch Symbols are saved to the Symbol Library, by default in C:\Users\Public\Documents\Autodesk\Inventor 2019\Design Data\Symbol Library
  • [Q] How do I make a sketch symbol of a ruler, 3 hole punch, GD&T symbols, etc
    • Drawing Resources → Sketch Symbols → right click Define New Symbol
  • [Q] How do you use a sketch symbol
    • Annotate tab → Insert Sketch Symbol
  • [Q] How do I save sketch symbols to a Symbol Library?
    • right click on Sketch Symbols and select “Save All to Symbol Library”
  • [Q] How do you change the color of a Sketch Symbol?
    • Appears you can only change the color of the parent, not the child. So if your parent sketch symbol is black and you then insert into a drawing. You CANNOT change the child instance to another color such as red. So the color is either ByLayer or I'm guessing ByBlock.

How to create a sketch symbol

  • Open block in AutoCAD, using the Clipboard copy with base point or Ctrl+C
  • Inventor → Open a Drawing template
  • from Model browser: Drawing Resources → Sketch Symbols → Create New Folder → ScalesRulers
    • How do I add sketch symbols to a folder? First create the symbol, then drag into the folder to organize
  • from Model browser: Drawing Resources → Sketch Symbols → Define New Symbol
  • Paste (Ctrl+V) in AutoCAD block
  • Create a point in the sketch where you want it to be a connection point (multiple)
  • Center Point
  • Connection Point Grip
    • Create a point in the sketch where you want the scalebar to snap to
    • Select the point, then toggle on Connection Point Grip (blue background)
  • Set Insertion Point Grip
    • Create a point in the sketch where you want it to be the insertion point (only one) → finish sketch
    • Select the point, then toggle on Set Insertion Point Grip, and toggle on Connection Point Grip
  • Finish Sketch
    • Name:
  • This creates a local sketch symbol, next need to save it to the Symbol Library
  • right click on sketch symbol in the browser and select Save to Symbol Library
    • Tools → Application Options → File tab → Sketch Symbol Library folder
      • asking to select an Inventor Drawing (Scales.idw)
      • default: C:\Users\Public\Documents\Autodesk\Inventor 2019\Design Data\Symbol Library
      • update: %USERPROFILE%\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\projects\Design Data\Symbol Library\
      • It appears the symbol library is saved in an Inventor drawings, e.g. Scales.idw
  • References

Borders in AutoCAD

Borders in Inventor

  • General
    • Margin0.50
    • Margin0.75
    • Margin1.00
  • Page Size Specific (includes border, 3 hole punch, ruler inch & mm, GD&T symbols)
    • 8.5×11-Margin0.50-Left-0.75-GDT
    • 8.5×11-Margin0.50-Left-0.75-GDTtop
    • 11×8.5-Margin0.50-Top-0.75
    • 17×11-Margin0.50-Left-0.75
    • 17×11-Margin0.75-Left-1.00
    • 17×11-Margin1.00-Left-1.25
  • Drawing Resources → Borders
  1. [Q] How do you change the page size of the border? I want to make a border for different paper sizes - 8.5×11, 11×17, 24×36
  2. [Q] How do I draw construction lines in the Border sketch? I want to make some reference guides, no-plot layers, similar to how dimensions don't plot
  3. [Q] How do I create different layers and/or lineweight of the Border? I want a thick lineweight for the Border, but thin lineweight and transparency for the GD&T table, etc
  4. [Q] How do I snap or dimension from the paper edge? I want a border with 0.75 left margin, the rest 0.5
  • Layer
    • lineweight 0.70mm (~ 0.028”) for 8.5×11
    • lineweight 0.50mm (~ 0.020“) for 8.5×11 and 11×17
  • Figure 3-0 Title block and Border - Size Letter - Orientation Portrait

Define 11x17 Border with 1 inch margin

  • Open template InchDecimal.dwg
  • Manage → Styles Editor → Layers → Border (ANSI) Line Weight 0.028” (~ 0.70mm)
  • Model Browser panel → Drawing Resources → Borders → right click Define New Border
  • Draw Rectangle with 1“ border around sheet
  • Finish Sketch
    • Name: 17×11-margin1.00
  • InchDecimal.dwg → right click New Sheet
  • right click on sheet and select Edit Sheet
    • Name 17×11
    • Size B
    • Orientation Landscape
  • Insert Border (Drawing Resources → Borders → 17×11-margin1.00 → right click Insert)

Define 11x17 Border with 1 inch margin and left 1.25 inch margin

  • Open template InchDecimal.dwg
  • Manage → Styles Editor → Layers → Border (ANSI) Line Weight 0.028” (~ 0.70mm)
  • Model Browser panel → Drawing Resources → Borders → right click Define New Border
  • Draw Rectangle with 1“ border around sheet
  • Finish Sketch
    • Name: 17×11-margin1.25left
    • Will notice the margin disappears. Still in the Drawing Resources, but now have to add it to the Drawing Sheet
  • InchDecimal.dwg → right click New Sheet
  • right click on sheet and select Edit Sheet
    • Name 17×11
    • Size B
    • Orientation Landscape
  • Insert Border (Drawing Resources → Borders → 17×11-margin1.25left → right click Insert)

Define 11x17 Border with 0.5 inch margin and left 0.75 inch margin

  • Open template InchDecimal.dwg
  • Manage → Styles Editor → Layers → Border (ANSI) Line Weight 0.028” (~ 0.70mm)
  • Model Browser panel → Drawing Resources → Borders → right click Define New Border
  • Draw Rectangle with 1“ border around sheet
  • Finish Sketch
    • Name: 17×11-Margin1.00-Left-1.25
    • Will notice the margin disappears. Still in the Drawing Resources, but now have to add it to the Drawing Sheet
  • InchDecimal.dwg → right click New Sheet
  • right click on sheet and select Edit Sheet
    • Name 17×11
    • Size B
    • Orientation Landscape
  • Insert Border (Drawing Resources → Borders → 17×11-margin1.25left → right click Insert)

Borders

  • 8.5×11-margin0.5
    • Layer Border, lineweight 0.70mm (~ 0.028”)
  • 11×8.5-margin0.5
  • 11×17-margin0.75
    • line properties - lineweight 0.055”, color black, corner fillet radius 0.1“
    • left margin 1.5”, top/right/bottom margin 0.75“
  • 17×11-margin0.75
  • 24×36-margin1.0
  • 36×24-margin1.0

Border 11x8.5

  • Inventor Border 11x8.5
    • Sketch Properties
      • Line Type Continuous
      • Line Weight 0.020”
      • Color Black

Border Text

  • Textstyle ArialNar05pt01x

Three Ring Holes - Sketch Symbol

  • Open InchDecimal.dwg
  • Model Browser → Drawing Resources → Sketch Symbols → right click Define New Symbol
  • Sketch - create the following
    • diameter of hole is 0.25“
    • Sketch Properties - Color light gray
      • right click on circle, then select Properties from the context menu/heads up display
      • Figure 3-0 Sketch Properties - Color
    • draw another hole, spacing is 4.25” apart
    • distance from edge of paper to center of hole is 0.5“
      • I don't know how to do this
    • Finish sketch
    • Right click on Sketch Symbols → ThreeRingHoles → Insert
      • How do you snap this to an exact location?
  • Problems
    • When I create the three holes, I'm unable to dimension to the edge of paper.
    • When I insert the ThreeRingHoles sketch symbol, I'm unable to dimension to the edge of paper
    • How do I change the color of the ThreeRingHoles to a light gray and not use the default layer color?
      • Sketch Properties → Color → Gray
  • LAYER JensenBorder-3ring (not sure how to create this layer and make it current when drawing sketches)
    • Line Weight 0.007 in
    • Line Type Continuous
    • Color light gray
  • 8.5×11 sheet of paper
  • Reference

Ruler - millimeters

  • Procedure
    • Have to manually draw each ruler in each drawing border, no way to insert a block or sketch symbol
  • Inventor Drawing Layout - Sketch Properties
  • Inventor → InchDecimal.dwg
  • Drawing Resources → Borders → 17×11-Margin0.50-Left-0.75
  • Line Weight 0.09 mm (0.007 inches in Inventor)
    • Sketch Properties → Line Weight → 0.007 in
  • Line Type Continuous
    • Sketch Properties → Line Type → Continuous
  • Color medium gray
    • Sketch Properties → Color (3rd from bottom right is too light/faint, try using bottom middle gray)
  • 10mm = 0.1476
  • 1 mm = 0.0492
  • 5 mm = 0.0984
  • Text
    • Font: ArialNar05pt
  • Inventor Drawing Layout - Position Ruler - mm

Ruler - Inches

  • Figure 3-0 Inch Ruler 16th of an inch
  • AutoCAD Block (C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\templates\Blocks\Ruler-Inch16th.dwg)
  • LAYER JensenBorder-inch16th
    • Line Weight 0.09 mm (0.007 inches in Inventor)
    • Transparency 20
    • Line Type Continuous
    • Color light gray
    • Tick mark lengths
      • 1” = 0.15
      • 1/2“ = 0.125
      • 1/4” = 0.10
      • 1/8“ = 0.075
      • 1/16” = 0.05
    • Text
      • Font: ArialNar05pt
      • INCHES (in or “)
      • 1/16 OF AN INCH

Ruler - Machinist

  • Figure 3-0 Machinist Ruler
  • AutoCAD Block (C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\templates\Blocks\Ruler-Machinist.dwg)
    • Layer - JensenRuler
      • Lineweight 0.09 mm
      • Transparency 20
    • Text Style
      • ArialNar05pt01x
    • 0 zero
      • length 0.15
    • 0.010 ten thou
      • length 0.05
    • 0.050 fifty thou
      • length 0.06
    • 0.100 hundred thou
      • length 0.075
    • 1.000 thousand thou
      • length 0.09

Geometric Dimension and Tolerance (GDT)

  • Objectives of GD&T
    • GD&T communicates a more precise part design, which can increase tolerances and reduce manufacturing costs by avoiding scrapped parts and saving time
    • GD&T is shown on a print - a document containing all the instructions necessary to manufacture a part. A print, or blueprint, includes a part drawing, dimensions, and notes.
    • Print includes the part's shape, dimensions and tolerances (allowable differences between a finished part and its intended design)
    • A datum represents a feature and establishes a reference for measuring and inspecting a part
  • Add to Border
  • Use Autodesk Inventor GDT font AIGDT

Feature Control Frame

  • Compartment 1
    • contains one of the 14 geometric control symbols
  • Compartment 2
    • tolerance for diameter or two parallel lines/planes
    • can also include modifiers
  • Compartment 3
    • primary datum
  • Compartment 4
    • additional datum references
  • Compartment 5
    • additional datum references

Material Condition Modifiers

  • Maximum Material Condition (MMC)
    • defines the most amount of material allowed for a feature to fit and function properly
    • for internal features such as a hole, MMC represents the smallest hole allowable
  • Least Material Condition (LMC)
    • defines the least amount of material allowable for a feature to function without too much looseness or slack
    • for internal features such as a hole, LMC represents the largest hole allowable
  • Bonus tolerance may be permissible if a feature deviates from MMC or LMC. Regardless of feature size (RFS) indicates that the tolerance applies regardless of its material condition and rules out the possibility of bonus tolerance.
  • Pin MMC and LMC

GDT on Left Margin

  • Border
    • offset 0.120”
    • color ACI# 252 (RGB 91, 91, 91) (little light - med gray)
    • linetype 0.007
  • Divider line between GD&T Symbols
    • dimension intervals 0.05“
  • Text Settings
    • Arial Narrow 5pt (0.05)
    • Justification Left Center
    • offset distance 0.060”
  • First Row
  • Diameter
  • Radius
  • Arc Length
  • Slope
  • Plus/Minus
  • Centerline
  • Counterbore
  • Countersink
  • Depth
  • Spotface
  • Taper
  • No. Times or Decimal Places
  • Surface Finish Mark
  • MMC
  • LMC
  • RFS
  • PROJECTED
  • TANGENT
  • FREE
  • Second Row
  • FORM
    • STRAIGHTNESS
    • FLATNESS
    • CIRCULARITY
    • CYLINDRICITY
  • PROFILE
    • PROFILE OF A LINE
    • PROFILE OF A SURFACE
  • LOCATION
    • POSITION
    • CONCENTRICITY
    • SYMMETRY
  • ORIENTATION
    • PARALLELISM
    • PERPENDICULARITY
    • ANGULARITY
  • RUNOUT
    • CIRCULAR RUNOUT
    • TOTAL RUNOUT
  • References
    • Engineering Drawing & Design 5th Ed by Madsen, p. 502

GD&T Videos

Scalebars

  • C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\dwg\blocks\ScalesRulers\ModelSpace-Feet
    • Figure 1-0 Architecture Scales
      • Ruler-Arch001-12in-to-1ft.dwg (1:1) (12“ = 1'-0”)
      • Ruler-Arch002-6in-to-1ft.dwg (1:2) (6“ = 1'-0”)
      • Ruler-Arch004-3in-to-1ft.dwg (1:4) (3“ = 1'-0”)
      • Ruler-Arch008-1.5in-to-1ft.dwg (1:8) (1 1/2“ = 1'-0”)
      • Ruler-Arch012-1in-to-1ft.dwg (1:12) (1“ = 1'-0”)
      • Ruler-Arch016-3-4th-to-1ft.dwg (1:16) (3/4“ = 1'-0”)
      • Ruler-Arch024-1-2nd-to-1ft.dwg (1:24) (1/2“ = 1'-0”)
      • Ruler-Arch032-3-8th-to-1ft.dwg (1:32) (3/8“ = 1'-0”)
      • Ruler-Arch048-1-4th-to-1ft.dwg (1:48) (1/4“ = 1'-0”)
      • Ruler-Arch064-3-16th-to-1ft.dwg (1:64) (3/16“ = 1'-0”)
      • Ruler-Arch096-1-8th-to-1ft.dwg (1:96) (1/8“ = 1'0”)
      • Ruler-Arch128-3-32nd-to-1ft.dwg (1:128) (3/32“ = 1'-0”)
      • Ruler-Arch192-1-16th-to-1ft.dwg (1:192) (1/16“ = 1'-0”)
      • Ruler-Arch384-1-32nd-to-1ft.dwg (1:384) (1/32“ = 1'-0”)
      • Ruler-Arch768-1-64th-to-1ft.dwg (1:768) (1/64“ = 1'-0”)
      • Ruler-Arch1536-1-128th-to-1ft.dwg (1:1536) (1/128“ = 1'-0”)
    • Figure 2-0 Civil Engineering Scales
      • Ruler-Civil-10.dwg (1=120)
      • Ruler-Civil-20.dwg (1=240)
      • Ruler-Civil-30.dwg (1=360)
      • Ruler-Civil-40.dwg (1=480)
      • Ruler-Civil-50.dwg (1=600)
      • Ruler-Civil-60.dwg (1=720)
    • Figure 2-0 Mechanical Engineering Scales
      • Scale-Mech-1to1.dwg (full)
      • Scale-Mech-1to2.dwg (half)
      • Scale-Mech-1to3.dwg
      • Scale-Mech-1to4.dwg (quarter)
      • Scale-Mech-1to8.dwg (eighth)
      • Scale-Mech-1to10.dwg (tenth)
      • Scale-Mech-2to1.dwg (double)
      • Scale-Mech-2to3.dwg
      • Scale-Mech-3to2.dwg
      • Scale-Mech-4to1.dwg
      • Scale-Mech-5to1.dwg
      • Scale-Mech-10to1.dwg
    • Figure 2-0 Mechanical Engineering Scales - double
      • Scale2-Mech-1to10.dwg
      • Scale2-Mech-1to8.dwg
      • Scale2-Mech-1to4.dwg
      • Scale2-Mech-1to3.dwg
      • Scale2-Mech-1to2.dwg
      • Scale2-Mech-2to3.dwg
      • Scale2-Mech-1to1.dwg
      • Scale2-Mech-3to2.dwg
      • Scale2-Mech-2to1.dwg
      • Scale2-Mech-3to1.dwg
      • Scale2-Mech-4to1.dwg
      • Scale2-Mech-5to1.dwg
      • Scale2-Mech-10to1.dwg
  • C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\dwg\blocks\ScalesRulers\PaperSpace-Inch
  • C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\Inventor\templates\Blocks\
    • scale-1to1-inch-single-anno.dwg
    • scale-1to2-inch-single-anno.dwg
  • Step 0 - create scalebars in AutoCAD
    • Architectural Scales
      • UNITS architectural (feet with ' and default is inches)
    • Civil 3D
      • UNITS decimal (feet )
  • Step 1 - create an AutoCAD drawing with all the scalebars inserted
    • lineweight 0.13mm
    • layer 0
    • color ByBlock (very important - then can change color within Inventor as Title Blocks can only go on layer TITLE and borders can only go on layers BORDER)
      • Inventor → within the Drawing, right click on the Block and select Properties
      • Block Properties
        • Line Type: By Layer
        • Line Weight: By Layer
        • Color: black
    • Civil 3D - C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\dwg\blocks\ScalesRulers\ModelSpace-Feet\Ruler-All-feet.dwg
  • Step 2 - open Inventor drawing template
  • Step 3 - Drawing Resources → AutoCAD Blocks → Import AutoCAD Blocks → open Ruler-All-feet.dwg
    • Problems
      • Inventor doesn't recognize annotative text
      • Cannot change the insertion point of a block in Inventor, have to do this in AutoCAD (Block Editor → Parameter Manager → Basepoint parameter to set insertion point - doesn't work), BASE doesn't work either. Seems like I need to recreate with WBLOCK
      • Cannot add additional connection points. Workaround copy and paste the block as a Sketch Symbol.

Drawing Resource Transfer Wizard

  • Use the Drawing Resource Transfer Wizard to copy drawing resources 1) borders, 2) title blocks, and 3) sketch symbols from a source drawing to one or more target drawings. Doesn't work with AutoCAD blocks.
  • Inventor Library does NOT save 1) borders, 2) title blocks, 3) sketch symbols in it. Seems like the Library saves settings, layers, styles.

Selling Inventor Templates

  • Create a zip folder of the following
    • Project File - same level as these folders
    • Templates Folder - include Parts, Drawings, Assembly templates
    • Design Data Folder
    • Designs Folder (the workspace should point here)
    • Preset Folder (this is for custom hole commands)

Multiview

Detail View

  • ASME Y14.3-2003 Multiview and Sectional View Drawings

Dimensions

  • Inventor Drawing
    • Annotate tab → Symbols panel → Feature Control Frame
  • Figure 1-0 Dimensions - Feature Control Frame
  • Problem - dimension and tolerance is static/hard coded, not dynamic
  • Dimension tool
    • Good - the overall diameter dimension is correct
    • Bad - the tolerance is static/hard coded, not dynamic
    • Bad - don't know how to add the Feature Control Frame to the dimension
    • Bad - even if the sketch has a tolerance, appears the only way to get it is to do retreive model dimensions which adds everything and is messy
    • Bad - appears a bug in “Retrieve Model Annotation” unable to just select a certain part

GD&T - Total Runout

  • Total Runout means workpiece diameter is within tolerance along the z-axis (turning axis) or the perpendicular face is within tolerance perpendicular to the z-axis
  • “Total runout provides a combined control of surface elements. This is a tolerance that blankets the surface to be controlled. Total runout is used to control the combined variations of circularity, straightness, coaxiality, angularity, taper, and profile when applied to surfaces constructed around and at right angles to a datum axis. The reference datums are always regardless of material condition.”
  • “Total runout can be used to control the combined variations of perpendicularity (to control wobble and flatness) and to control concavity or convexity when applied to surfaces perpendicular to a datum axis. The total runout tolerance zone encompasses the entire surface as the part is rotated 360°. The entire surface must lie within the specified tolerance zone. To determine this, the dial indicator is placed at every location along the surface as the part is rotated 360°. Total runout is shown in Figure 13.105.” (Engineering Drawing & Design by Madsen and Madsen, 5th, p. 544-5)
  • Figure 1-0 GD&T Total Runout

Hole Table

  • Add a hole table for all holes in a view
    • Annotate tab → Table panel → Hole, click arrow next to Hole command then select Hole View
    • in graphics window, select the drawing view
    • click a point to place origin indicator for the hole table
    • click to place the hole table. Hole tags display in the view next to each hole
  • Hole Table Title
  • How to add a custom column to the hole table
    • right click on the Hole Table and select Edit Hole Table from context menu
    • Formatting tab
    • Column Chooser
      • New Property
        • DRILL SIZE
    • Add button to move to Selected Properties
    • Manually edit table values
      • double click on the “-” to change the value (note it pain/difficult to select)
    • Hole Table - Add Column
  • Problems
    • no padding to the right of text on right justified values in a table
    • How do I display the fraction for tap drill diameter instead of the decimal number
  • Reference

Chamfers

  • Inventor Drawing → Annotate tab → Chamfer
    • First select the chamfer edge
    • Second select the adjacent horizontal/vertical line
    • Third click where you want to place the label such as .03 X 45° Chamfer

Drawing Annotation

  • Steps to change the text size/height
  1. Manage tab > Styles Editor from the Styles and Standards panel > Text > Note Text (ANSI) > New… button
    1. Figure 1-0 Autodesk Inventor - Create New Note Text
  2. Name it Note Text Jensen and change the Text Height from 0.120 inches to 0.200 inches
    1. Figure 1-0 Autodesk Inventor - Change Note Text Size
  3. Save
  4. select Dimension > Architectural (ANSI) > Units tab
    1. Figure 1-0 Autodesk Inventor - Change Note Text Units
    2. Figure 1-0 Autodesk Inventor - Change Note Text Units

Title Blocks

References

Retrieve Dimensions

NIMS Lathe Drawing

  • National Institute for Metalworking Skills (NIMS) Machining Skills Level 1 - Job Duty 2.3 - Turning Between Centers
  • Figure 1-0 NIMS Turning Between Centers
  • Figure 2-0 NIMS Turning Between Centers - 2D Drawing
  • Figure 1. Table 6. American National Standard Combined Drills and Countersinks - Plain and Bell Types, Machinery's Handbook, 27th Edition by Industrial Press, p. 873
  • Figure 1-0 NIMS Turning Between Centers - No. 4 Center Drill Dimensions Detail
  • Figure 2, ANSI Standard Twist Drill Nomenclature, Machinery's Handbook, 27th Edition by Industrial Press, p. 855

Machining Procedure

  1. get 7-8“ long, cold rolled steel, 1” diameter
  2. Lathe, 3 jaw chuck, with workpiece extending 2“ out of chuck
    1. Face
    2. Turn to 0.900”
    3. Chamfer
    4. Center drill
    5. remove from chuck
  3. Lathe, reverse workpiece extending 2“ out of chuck
    1. Face
    2. Chamfer
    3. Center drill
    4. remove from chuck
  4. Lathe, Collet and install live center in tailstock
    1. Rough cuts - Turn to 0.900”
    2. Parting tool 0.125“ - cut 3 thread reliefs
    3. Turn 2.375” from right down to 0.750“
    4. Turn 3 faces that maintain concentricity
      1. Turn 3.375 to 5.125 down to 0.750” (concentric 1 of 3)
      2. Turn 1.500“ from right down to 0.625” (concentric 2 of 3)
      3. Turn 1.000“ from right down to 0.500” (concentric 3 of 3)
  5. Lathe, cut threads
    1. Turn 4.5 to 5.125“ down to 0.625”
    2. Turn chamfers
    3. Thread 4.5 to 5.125“ with 1/2”-13 TPI UNC-2A (A = air or outside)
    4. Thread 1.5 to 2.375 with 3/4“-16 UNF-2A
  6. Knurl
  7. Bandsaw - cut 2” off used to hold in chuck
    1. grind off any burrs
    2. polish
  8. Surface treatment
  9. Heat treatment

NIMS Machining Skills Level 2

Equipment - Cutting Tools

Knurl in 3D part model view

  • Issues showing a knurled surface - Autodesk Inventor - Knurled 45 appearance not displaying properly by Adam Forney. For some reason this video only played in Google Chrome (got error using Firefox and IE).
    • Step 1 - select part face to be knurled and assign the “Knurled 45” material to it.
    • Step 2 - open the Appearance Browser, right click on the “Knurled 45” material and select Edit
      • Figure 1-0 Assign and Edit Knurl 45 material
    • Step 3 - Change the Relief Pattern type from Knurl to Custom Image
      • Figure 2-0 Knurl Relief Pattern - Custom Image
    • Step 4 - assign knurl image (C:\Users\Public\Documents\Autodesk\Inventor 2015\Textures\bumpmaps\Knurl_bump.bmp)
    • Step 5 - change sample size to 0.08 inches (click the image to open the Texture Editor dialog box)
      • Figure 3-0 Knurl Sample Size
    • Note - the knurl texture pattern will only display in a drawing (.idw) isometric view that is shaded. Will not be shown in a multiview drawing.

Knurl in 2D part drawing view

  • Step 1 - open Inventor drawing file (.idw)
  • Step 2 - select the right or top view border (red dotted line) you want to apply a hatch to
  • Step 3 - Ribbon → Place Views tab → Start Sketch (open the Sketch tab)
  • Step 4 - Sketch > Project Geometry and select the boundary
  • Step 5 - draw a rectangle over the projected geometry, ensure it snaps to the edges so it remains dynamic
  • Step 6 - Ribbon: Click “Hatch Region” button (keep this open)
  • Step 7 - select rectangle from step 5
  • Step 8 - change hatch pattern from step 6, then click OK
  • References
  • Problem - the lineweight is too thick, how do I change it?
  • Figure 3-0 Object Defaults Style

Materials

Auxiliary and Broken Section Views

  • Figure 1-0 Technical Drawing with Engineering Graphics, 114th Edition by Giesecke, Mitchell, Spencer, Hill, Dygdon, Novak and Lockhart, Exercise 8.15 45° Elbow, p. 320, with corrections

Section Views in Model Part

Section Views in Drawings

Drawing Layout References

Navigation

Civil Engineering Engineering - Computer Engineering - Electrical Mechanical Engineering

Print/export
QR Code
QR Code engineer-mechanical:inventor-drawinglayouts (generated for current page)