Shopping Cart

Sketches

Planes

  • How to create planes at compound angles (would be nice if you could create a plane through 3 points)
  • Step 1) create a construction centerline in a sketch, then exit the sketch
  • Step 2) create reference geometry
    • Ribbon: Features → Reference Geometry button → Plane
    • Menu: Insert → Reference Geometry → Plane
  • Step 3) select reference
    • First Reference → select the construction line/centerline from the sketch above
    • Second Reference → select a face you want to angle the reference plane from
      • enter an angle, say 45 degrees
  • SOLIDWORKS Help - Plane PropertyManager

Windsor 3 legged Stool

Getting Started

  • Title Blocks examples
  • Think size and position
    • When creating a part from a 2D sketch, you need to define both the size of the part using dimensions and relationships (e.g. coincident) and its position/relationship to the origin (0,0)
    • Typically in AutoCAD details we are only concerned with defining size/dimensioning the part. With Solidworks and Inventor, we need to also define its position.
    • Defining a position is easy to understand by surveyors, GIS, and civil engineers. Little harder to understand by Architects and Structural Engineers.
    • Fully Defined - when a sketch contains exactly enough dimensions and/or relations to define its size and position in space.
  • New
  • Options → Document Properties
  • Units and Dimension Standard
    • Units: IPS (inch, pound, second) - displayed in the status Bar (bottom right corner of SolidWorks)
    • Dimension standard: ANSI
    • Note - the Units and Dimension Standard box only appears the first time SolidWorks is opened. The selections become the default values for all new files.“ (Introduction to Solid Modeling - Using SolidWorks 2014 by Howard & Musto, p. 6)
  • Part, Assembly, Drawing, Tutorial
    • Tutorial → Student Curriculum → Engineering Drawing Tutorials for Visualization
  • View → Toolbars
    • Turn on Standard Views (right click ribbon and select Standard Views)
  • Tools → Options - System Options tab
    • Colors
    • Sketch
      • Enable Auto-rotate view normal to sketch plane on sketch creation (will behave like Inventor)
      • Enable on screen numeric input on entity creation
      • also Enable on “Create dimension only when value is entered”
        • Figure 2-0 Options - Numeric Input
      • Note - can only enter the length/distance not the angle, after to do this after you have sketched the line
    • File Locations
      • Show folders for: Document Templates
        • C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\SolidWorks\template
          • move up to top
      • Show folders for: Sheet Formats
        • C:\Users\jjensen.CI\journeyeducation.org\Jensen - Documents\JeffJensen\GISEngineering\SolidWorks\template
          • move up to top
    • View
      • Reverse mouse wheel zoom direction
        • checked on - I move - like if I have a jetpack on
        • checked off - I'm fixed - pull things to me
    • Customize
      • Commands → View Group → Rotate View Tool → drag onto the Heads-Up View Toolbar
      • Commands → View Group → Pan Tool → drag onto the Heads-Up View Toolbar
  • Tools → Options → Document Properties tab
    • Bug with Century Gothic Font - unable to edit dimensions, see Smart Dimensions Not Working
    • Annotations → Font → Arial Narrow
    • Dimensions → Font → Arial Narrow
    • Tables → Font → Arial Narrow
    • Detailing → Name font → Arial Narrow
    • Detailing → Label font → Arial Narrow
    • Dimensions
      • Primary precision .123 (default is .12)
    • Figure 2-0 SolidWorks Drawing - Century Gothic
  • Pin SolidWorks Menu
    • Click SolidWorks application menu to open fly-out menu, then click right pushpin (this disables the fly-out menu so it is always displayed.
  • CommandManager or Ribbon (as called by Inventor)
    • make sure Features and Sketch tabs are visible
  • FeatureManager Design Tree
    • Displays the green check mark
  • Heads-Up View Toolbar
  • Context-Sensitive Menus
  • Document Properties tab

Properties of Parts

  • Mass Properties (Tools → Evaluate → Mass Properties)

Threads

  • Part → Annotations
    • check on Shaded cosmetic threads

Equations

  • Turn Equations on in the Feature Manager
    • Options → System Options tab → FeatureManager
      • Equations: default is Automatic, change to Show
      • OK
      • Figure 2-0 Options - FeatureManager - Equations
  • Tools → Equations
    • A =63
    • To use in smart dimension, type =, then pick global variables
    • Figure 2-0 Equations
  • When editing equation values, will need to rebuild SolidWorks part to see changes (think this is done automatically)

Configurations

  • Create configuration first
  • Create equations
  • Create sketch

Dimensions

  • Dimensions in SolidWorks drawing are associated with the model and changes in the model are reflected in the drawing
  • DimXpert tools used to insert dimensions and tolerances into a part. You can import these dimensions and tolerances into drawings. DimXpert is NOT associative.

Geometric Dimensions & Tolerances GD&T

  • Font
    • Symbol - has radical/square root symbol used for surface finish
    • AIGDT
    • AMGDT
    • GDT
    • SWGDT

Assemblies

AutoCAD Title Block - Letter - Portrait - Simple

  • Open AutoCAD using acad.dwt template
  • Layout1 tab
  • delete viewport
  • PAGESETUP
    • New
    • name: 8.5x11simple
    • Printer/plotter
      • Name: DWG To PDF.pc3
    • Paper size
      • ANSI full bleed A (8.50 x 11.00 Inches)
    • Plot offset
      • X: 0
      • Y: 0
    • Plot style table: monochrome.ctb
    • Plot options
      • check on Plot transparency
    • Drawing orientation: Portrait
  • LAYER
  • Draw Edge of Paper
  • Draw Border
    • Left Margin 0.75”
    • Top, Bottom, Right Margin 0.5“

Three Ring Holes

  • LAYER JensenGrid
  • 8.5×11 sheet of paper
  • hole space is 4.25” apart
  • distance from edge of paper to center of hole is 0.5“
  • diameter of hole is 0.25”
  • Reference

Third Angle Projection

  • STYLE ArialNar04pt01x
  • draw 1 inch wide by 0.5 inch tall box in lower left corner
  • draw two concentric circles on the left
  • draw cone on the right
  • draw centerlines

Drawings

  • Layouts are called sheet formats in SolidWorks
    • File → Save Sheet Format…
  • AutoCAD Layout and SolidWorks Sheet Format
    • Tools → Options → System Options → Drawings then disable Automatically scale new drawing views
        • login jjensen5@csi.edu bd#
        • Solution ID: S-071870, Question: When I insert a model view, what causes pictures, tables, or notes that I insert in a drawing to scale or move?
        • Figure 2-0 Solution ID: S-071870
  • Standard sheet size - B (ANSI) Landscape - width 17-inch and height 11-inch
  • Part/Assembly to Insert
  • Figure 2-0 Drawing Centermark Extended Lines
  • Add plot stamp/field codes/file path and name
    • Open SolidWorks drawing
    • Annotation tab
    • Note
      • Text Format → Link to Property button
      • place in lower left corner
      • Property name: SW-Folder Name(Folder Name)
      • place in lower left corner
      • move cursor to end of textbox
      • Property name: SW-File Name
      • How do you add the filename extension?

Section Views

Sheet Formats and Drawing Templates

  • Background: drawing templates have a link to the sheet formats (really just a copy since if you change the title block in the sheet format, the drawing template has to manually be edited)
  • Step 1 - add path to where you save custom drawing templates (.DRWDOT) and sheet formats (.SLDDRT)
    • Options → System Options → File Locations
      • from the drop down menu select
      • Document Templates
      • Sheet Formats
  • Step 2 - Edit Sheet Format
    • to exit right click again and choose Edit Sheet
  • Step 3 - Save Sheet Format (export)
    • default: C:\ProgramData\SOLIDWORKS\SOLIDWORKS 2017\lang\english\sheetformat
  • Step 4 - Link Sheet Format to Drawing Template (.DRWDOT)
    • Sheet Properties (right click on the drawing sheet and select Properties)
    • Browse button
    • Make any changes to the Options → Document Properties
    • File → Save As
      • Save as type: Drawing Templates (*.drwdot)
  • Step 5 - New
  • Step 6 - Edit Titleblock to customize to current drawing
    • edit text fields by right clicking on the titleblock and selecting Edit Sheet Format
    • double click the text to edit
    • close Edit Sheet

References

Title Block Requirements

  • Figure 2-0 SolidWorks Titleblock Letter Size - Landscape
  • Sheet Size
    • Letter 8.5×11 landscape - unit inches, ANSI A, (215.9 by 279.4 mm)
    • Tabloid 11×17 landscape - unit inches
    • A4 in mm 210 mm × 297 mm (8.27 in × 11.7 in)
    • A3 in mm 297 mm × 420 mm (11.7 in × 16.5 in)
  • Font
    • Arial Narrow
  • Part Name - Title
  • Business/Company Name
    • address
    • email
    • phone#
    • web address
    • logo
  • Assembly Name - Parent Title
  • Sheet Number
  • Scale and Sheet Size
  • Units
    • “UNLESS OTHERWISE SPECIFIED, ALL DIMENSIONS ARE IN INCHES (IN)”
    • “UNLESS OTHERWISE SPECIFIED, ALL DIMENSIONS ARE IN MILLIMETERS (mm)”
      • (ASME-Y14.100-2004 Engineering Drawing Practices, p. 8)
    • 0.9 mm (don't use .9 for millimeters)
    • .9 IN (don't use 0.9 for inches)
      • “A zero is not used before the decimal point for values less than 1 in”
    • Tolerances
  • Material
  • Cover Sheet
  • Plot Stamp
    • File path and name
    • Date Plotted (e.g. DATE OF PRINTING: 6 MAR 2018)
    • “The method of specifying dates on drawings shall be numerical by year-month-day for entry in the 'DATE' block. For example, June 10, 1989 would be indicated as 1989-06-10, 89-06-10, 19890610, 890610, 1989/0610. pr 89/06/10.” (ASME-Y14.100-2004 Engineering Drawing Practices, p. 8)
  • General Notes Sheet
    • linetype legend
    • abbreviations
    • Drafting Standard used (ASME Y14.5-2009)
    • Tolerance
    • GD&T definition - symbols
      • Flatness
      • Squareness
      • Parallelism
      • Concentricity
      • Roundness
      • Run out
    • material specifications
    • Sand Casting requirements
    • Machining setup procedures
    • Feature Control Symbol (Technical Drawing, 4th by Goetsch & Chalk, p. 483)
      • Figure 2-0 Feature Control Symbol
  • REVISIONS BLOCK

Layers

Title Block

  • Options → Document Properties
    • Annotation: Font, Font Style: Narrow, Height 5pts
  • New → Drawing
  • Standard sheet size: A (ANSI) Landscape
    • Width: 11.00in and Height: 8.50in
    • uncheck “Display sheet format”
    • OK
  • If you have a part already open, will get Model View, just click the red x
  • right click Sheet1 and select Properties…
    • Name: 11×8.5
  • right click on Sheet1 and select “Edit Sheet Format”
  • scale 1:1
    • Problem, when I change the scale, it scales the layout border and title block, so how to make it paperspace?
  • Line Format Toolbar
    • View → Toolbars → Line Format
    • Layer
      • Border
      • Thickness: 0.0197 line thickness
    • draw border (see below)

Dimensions

  • To hide, just right click on the dimension and select Hide
  • To unhide, View → Hide / Show → Annotations
    • This shows the dimension grayed out, manually select the one you want to unhide

Border

  • SolidWorks Drawing need to right click and select Edit Sheet
    • Sheet Formats (*.drt, *.slddrt)
  • View → Toolbars → Line Format
  • Make a new layer - Border
    • Thickness 0.0197in
  • Make a new layer - Border
  • Draw a rectangle, then will dimension to exact size. Problem, SolidWorks cannot dimension to edge of paper.
    • Landscape view
    • Margin Top = 0.6“
    • Margin left, bottom, right = 0.4”
  • select lower left corner, then change fixed properties
    • fixed, 0.4, 0.4
  • select upper right corner, then change fixed properties
    • fixed, 10.6, 7.9
  • (optional) fillet radius 0.10“ at 4 corners

Title Block

  • View → Toolbars → Line Format
  • Make a new layer - TitleBlock
    • Thickness 0.0138in
  • Make TitleBlock layer current, first button on toolbar

Logo and Address

  • SolidWorks Drawing need to right click and select Edit Sheet
  • Insert → Picture
    • Transparency → From file (if it has transparent background)
  • Note
    • turn off leader button
  • Insert → Picture
  • Line 1: College of Southern Idaho
  • Line 2: Manufacturing Technology
  • Line 3: James Kellis (jkellis@csi.edu)
  • Line 4: 208-732-6379
  • Line 5: tradeindustry.csi.edu/manufacturing

Project Name and Description

  • SolidWorks Drawing need to right click and select Edit Sheet
  • Annotation tab → Note
  • Style → ArialNar05pt

Filename and Path

  • SolidWorks Drawing need to right click and select Edit Sheet
  • Layer PlotStamp
  • Annotation → Note
  • Add plot stamp/field codes/file path and name
    • Open SolidWorks drawing
    • Annotation tab
    • Note
      • Text Format → Link to Property button
      • place in lower left corner
      • Property name: SW-Folder Name(Folder Name)
      • place in lower left corner
      • move cursor to end of textbox
      • Property name: SW-File Name
      • How do you add the filename extension?

SolidWorks Blocks Issues

  • SolidWorks 2017 cannot import AutoCAD 2018 DWG or DXF, need to save to 2013 version
  • When importing DWG blocks as SolidWorks Blocks (Tools → Block → Insert)
    • Hatch pattern is not preserved, so have to manually change
    • No Plot Layers are not preserved, have to manually change the layer setting to “will not print”
    • AutoCAD text size comes in slightly bigger in SolidWorks, so 5pt (0.05”) in AutoCAD is 4pt (0.04“) in SolidWorks

Scale and Scalebar

    • RECT 1” by 0.0625“
    • STYLE ArialNar05pt01x
    • Text is offset 0.02”
    • BLOCK
      • Scalebar1to1-in
    • WBLOCK
  • Figure 1-0 Scalebar Dimensions
    • Tools → Block → Insert
    • Options → System Options tab → File Locations → Show folders for: Blocks
      • Figure 1-0 System Options - Drawing - Blocks
    • File Types
      • SOLIDWORKS Blocks (*.sldblk)
      • SOLIDWORKS Blocks (*.sldsym) - older format
      • AutoCAD DWG Blocks (*.dwg)
      • AutoCAD DXF Blocks (*.dxf)
    • To Create/Make a Drawing Block
      • Tools → Blocks → Make
    • To Save a Drawing Block
      • default is saved in the local drawing created in
      • To save to a file, use Tools → Block → Save
  • SolidWorks Layers - Layers
    • support will not print (not colored icon) or will print (light blue color on)
  • Drawing → Annotation tab → Area Hatch/Fill
    • Region - must be a planar face
    • Boundary -
      • Free hand sketch, that is draw a new sketch/rectangle over the curved surface to hatch it, this is a workaround
  • Try making the scalebar as a SolidWorks block with an area hatch
  • Use Adobe Acrobat Pro
  • Tools → Content Editing → Edit Text & Images
  • Select the “SOLIDWORKS Education Product. For Instructional Use Only.”
    • press Delete key on the keyboard to remove

Vocabulary

  • Fully Defined = Fully Constrained (Inventor)
    • Under Defined - sketch is blue color, need to add either dimensions, relationship/constraints, position
    • Over Defined - sketch is red color, has at least one dimension or relationship that contradicts or is redundant to other dimensions/relations
  • Construction Lines can be used to model X, Y, Z axis which Axis is already available in Inventor. Can also rotate around a construction line in SolidWorks.
    • Features Ribbon → Reference Geometry → Axis

Sweeps - Threads

Split Parts Parting Line

  • Open part to split (1-RSC-405_Frame.SLDPRT)
  • Have a plane visible/selected (right click and select eyeball)
  • Insert → Molds → Split
  • Cut Part button
  • Resulting Bodies
  • click Green checkmark
  • The part disappears, move the horizontal bar in the FeatureManager tree above Split1 to view it

Certification

  • CSWA Sample Exam - www.solidworks.com/cswa
  • CSWA Academic - Certified Solid Works Associate
  • CSWP Academic - Certified SOLIDWORKS Professional
  • CSWPA-Drawing Tools - Certified SOLIDWORKS Professional Advanced Drawing Tools
  • Sketch Relations is the same as Inventor Constraints
    • “Relations can be deleted by clicking on the relation icon to select it, and then pressing the Delete key. The display of sketch relations can be toggled on and off by selecting View from the Main Menu and clicking Sketch Relations.” (Introduction to Solid Modeling Using SolidWorks 2014 by Howard & Musto, p. 12)
    • Figure 2-0 Sketch Relation Icons

CSWA Certified SolidWorks Associate

References

Sketch Entities - lines, rectangles, circles, arcs, ellipses

Centerlines

Sketch tools - offset, convert, trim

Sketch relations

Boss and cut features - extrudes, revolves, sweeps, lofts

Revolve Cut
  • Need 1) axis of rotation and 2) profile/closed feature. It appears these have to be in the same sketch, can't have two sketches, one with a closed path/sketch and the other with an axis of rotation. Don't have the ability to select features, can only select the axis of rotation.
  • Doesn't work with Features, use Circular Patterns instead

Fillets and chamfers

Linear, circular, and fill patterns

Dimensions

Feature conditions - start and end

Mass properties, Center of Mass

Equations

Materials

Inserting components

Standard mates - coincident, parallel, perpendicular, tangent, concentric, distance, angle

Reference geometry - planes, axis, mate references

Drawing views

Annotations

RealView

CSI Materials

  • Steel - AISI 1020
  • Aluminum - 1060 Alloy
  • FeatureManager Tree → Material → Edit Material

Tutorials

SolidWorks Consultants

Video Tutorials

Projects

Part 110 Wheel Rim

  • Figure 1-0 Wheel Rim

Part 1

  • Figure 1-0 Wheel Rim Description Part 1

Part 2 - Create Spokes

  • Figure 1-0 Wheel Rim Description Part 2
  • Plan of Attack
    • Create a sketch of the gap area between two spokes
    • Use Extrude Cut to remove the area
    • Use Circular Pattern to copy the gap area 15x around the wheel rim. Don't need an axis of rotation, only have to select a circular face/plane used to rotate around

Part 120 Half Tube

  • Figure 1-0 Half Tube Description Part 1

Part 1

  • Figure 1-0 Half Tube Description Part 1

Part 2

  • Figure 1-0 Half Tube Description Part 2
  • Answer C, I get mass 6708.85 grams

Part 125 Double Angle

  • Figure 1-0 Part 125 Double Angle Description

Assembly Projects

SolidWorks License Options

  • Go Engineer - Education Dave Alpert, Direct: 760.473.3024 or dalpert@goengineer.com
    • Education License
      • files can be opened by commercial license but will retain the educational watermark
    • Academic Research License is 50% discount
    • Standard License is \$4000 + \$1300 annual maintenance
    • Professional License is \$5500 + \$1500 annual maintenance
    • Premium License is \$8000 + \$2000 annual maintenance
Navigation

Civil Engineering Engineering - Computer Engineering - Electrical Mechanical Engineering

Print/export
QR Code
QR Code engineer-mechanical:solidworks (generated for current page)